Akamai Status

Updated

Certificate Provisioning System (CPS) recurrence of issues in Akamai Control Center Portal

Incident Report for Akamai

Monitoring

We have implemented a fix for this issue as of 22:10 UTC on 11 February 2026; based on current observations, the service is resuming normal operations. We will continue to monitor until tomorrow US afternoon hours to ensure that the impact has been fully mitigated.
Posted Feb 11, 2026 - 23:05 UTC

Identified

We are investigating an emerging issue with Certificate Provisioning System (CPS) where users may have issue accessing via Akamai control center. The issue is identified and we are actively working the mitigation plan and will provide another update as progress is made.
Posted Feb 11, 2026 - 21:09 UTC
This incident affects: Configuration (TLS Provisioning).