Akamai Status

Updated
Potential Edge HTTPS Delivery Issues in a Limited Set of North/South American and European Regions
Incident Report for Akamai
Resolved
We can confirm that the issue is now resolved as of 2:03 UTC on 14 May, 2024 and the service has resumed normal operation. Customers and partners can view additional details about the incident by logging in to: https://community.akamai.com/customers/s/feed/0D54R0000AheBwtSQE?language=en_US or reaching out to Akamai Support.

We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted May 14, 2024 - 02:15 UTC
Update
We continue work to implement the fix with a new ETA of approximately 2 hours to completion. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AheBwtSQE?language=en_US. We will provide an update once more information becomes available.
Posted May 13, 2024 - 23:56 UTC
Update
We continue work to implement the fix with an ETA of approximately 4 hours to completion. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AheBwtSQE?language=en_US. We will provide an update once more information becomes available.
Posted May 13, 2024 - 20:21 UTC
Identified
We have identified the cause of the issue, and a fix is being implemented. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AheBwtSQE?language=en_US. We will provide another update within the next 60 minutes.
Posted May 13, 2024 - 19:20 UTC
Investigating
We are investigating an emerging issue with potential Edge HTTPS Delivery connectivity issues. We are actively investigating the issue and will provide another update within the next 60 minutes.

If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community, or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted May 13, 2024 - 18:32 UTC
This incident affected: Content Delivery (Edge Delivery).