Akamai Status

Updated

Edge Delivery Issues in NASA (North America and South America)

Incident Report for Akamai

Resolved

We can confirm that the issue was mitigated at 1:30 UTC on June 6, 2026 and the service has resumed normal operation. Customers and partners can view additional details about the incident by logging in to: https://community.akamai.com/customers/s/feed/0D5a700001CQ6lqCAD or reaching out to Akamai Support. We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Jun 06, 2026 - 07:21 UTC

Investigating

We became aware of an issue with Edge Delivery in Americas Region related to elevated request denials and service degradation between 1:00 UTC and 1:30 UTC on June 6, 2026. We are actively investigating the cause of the service degradation within the affected environment and assessing customer impact. At this time, the issue appears to have stabilized, and we will continue to monitor the platform closely. We will provide additional updates as we make further progress in our investigation. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D5a700001CQ6lqCAD.
Posted Jun 06, 2026 - 04:29 UTC
This incident affected: Content Delivery (Edge Delivery).