Akamai Status

Updated

Potential Phishing Attempt Targeting Coinbase Customers

Incident Report for Akamai

Resolved

Akamai is aware of reports regarding a potential phishing scam targeting Coinbase users that involves an Akamai email domain. We take information security very seriously and are actively investigating the matter.

Phishing scams remain a prevalent cyber threat, and we urge all users to exercise caution if they receive unsolicited emails, especially those requesting personal or account information. If you suspect that an email may be a phishing attempt, please treat it as such and avoid clicking any links or providing any sensitive information.

We are working to address the situation and will continue to monitor and mitigate any related risks. In the meantime, we recommend heightened vigilance to help protect your personal information.

Thank you for your understanding as we work to resolve this issue.
Posted Mar 14, 2025 - 15:00 UTC