Akamai Status

Updated
Akamai Multi-Factor Authentication Issues
Incident Report for Akamai
Resolved
We can confirm that the issue is now resolved as of 22:20 UTC on June 15, 2022 and the service has resumed normal operations. Customers and partners can view additional details about the incident, by logging in to https://community.akamai.com/customers/s/group/0F90f000000DFgx/service-incident-notifications or reaching out to Akamai Support.

We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Jun 15, 2022 - 22:26 UTC
Identified
We have identified the cause of the issue, and a fix is being implemented. We will provide another update within the next 60 minutes.
Posted Jun 15, 2022 - 22:04 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R00008vfUTLSA2. We will provide another update within the next 24 hours.
Posted Jun 15, 2022 - 18:00 UTC
Investigating
We are investigating an emerging issue with Akamai Multi-Factor Authentication related to Reporting Dashboard and Authentication Events information not populating in the Enterprise Center. We are actively investigating the issue and will provide another update within the next 30 minutes.

If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community, or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted Jun 15, 2022 - 17:31 UTC
This incident affected: Enterprise Security (Akamai MFA).