We can confirm that the issue was mitigated at 6:00 UTC on 21 March, 2025 and the service has resumed normal operation. Customers and partners can view additional details about the incident by logging in to: https://community.akamai.com/customers/s/feed/0D5a700000LFdNMCA1 or reaching out to Akamai Support.
We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Mar 21, 2025 - 10:06 UTC
Monitoring
We have implemented a fix for this issue as of approximately 6:00 UTC on 21 March, 2025; based on current observations, the service is resuming normal operations. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D5a700000LFdNMCA1. We will continue to monitor to ensure that the impact has been fully mitigated.
Posted Mar 21, 2025 - 06:36 UTC
Investigating
We are investigating an issue with EAA where customers are experiencing slowness and availability issues while accessing the management console. We are actively investigating the issue and will provide another update within the next 30 minutes.