Akamai Status

Updated

Enterprise Application Access (EAA) Management Console Issues

Incident Report for Akamai

Resolved

We became aware of an issue with EAA related to Management console being inaccessible due to high connection load on the database that lead to increased CPU utilization.
The issue lasted between 2:00 UTC on 21, March, 2025 and 3:45 UTC on 21, March, 2025.

We can confirm that the issue is now resolved, and the service has resumed normal operation.

We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Mar 21, 2025 - 05:03 UTC