We are continuing to work to identify opportunities for increasing capacity in the Chennai, IN (MAA) region to prevent issues during peak traffic hours. The current ETA for the hardware replacement effort is end of day on April 29, 2026. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D5a7000015jW2OCAU. We will provide an update as we progress.
Posted Apr 28, 2026 - 17:44 UTC
Investigating
We have identified an issue with a network resource failure in the MAA (Chennai, IN) region related to intermittent delays and timeouts during peak traffic hours with Delivery and other Akamai services that traverse into/through the MAA region. We are actively investigating opportunities to increase network capacity in the region while working to replace the failed resource as quickly as possible. An update will be provided in 60 minutes. We will soon be posting more details for customers and partners with a valid Control Center login at https://community.akamai.com/customers/s/group/0F90f000000DFgx/service-incident-notifications. If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community (https://community.akamai.com/customers/s/support), or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted Apr 28, 2026 - 16:42 UTC
This incident affects: Content Delivery (Edge Delivery) and App & Network Security (Bot Management).