Akamai Status

Updated
HTTPS Edge Delivery Issues for v103 of Chrome Browser
Incident Report for Akamai
Resolved
We can confirm that the issue is now resolved as of 18:30 UTC on June 30, 2022 and the service has resumed normal operations.
Customers and partners can view additional details about the incident, by logging in to https://community.akamai.com/customers/s/group/0F90f000000DFgx/service-incident-notifications or reaching out to Akamai Support.
Posted Jun 30, 2022 - 18:58 UTC
Monitoring
We have implemented a fix for this issue as of 18:10 UTC on June 30, 2022. Based on current observations, the service is resuming normal operations.
We will continue to monitor to ensure that the impact has been fully mitigated.
Posted Jun 30, 2022 - 18:14 UTC
Update
The fix continues to be implemented. We will provide an update within the next 3 hours.
Posted Jun 30, 2022 - 15:04 UTC
Update
The fix continues to be implemented. We will provide an update within the next 3 hours.
Posted Jun 30, 2022 - 12:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 30, 2022 - 07:48 UTC
Identified
We have identified the cause of the issue, and a fix is being implemented. We will provide an update within the next 2 hours.
Posted Jun 30, 2022 - 06:02 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R00008xu5JwSAI. We will provide an update within the next 2 hours.
Posted Jun 30, 2022 - 03:48 UTC
Investigating
We are investigating an issue with Chrome Browser v103 related to QUIC errors. We are actively investigating the issue and will provide another update within the next 60 minutes.

If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community (https://community.akamai.com/customers/s/support), or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted Jun 30, 2022 - 03:26 UTC
This incident affected: Content Delivery (Edge Delivery).