Akamai Status

Updated
Edge Delivery issues in North America
Incident Report for Akamai
Resolved
We are aware of an issue with Edge Delivery related to customers experiencing connectivity issues.
We can confirm that the issue is now resolved as of 11:10 UTC on May 11, 2023, and the service has resumed normal operation. Customers and partners can view additional details about the incident by logging in to: https://community.akamai.com/customers/s/feed/0D54R00009pPfnUSAS or reaching out to Akamai Support.

We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted May 11, 2023 - 07:30 UTC