Akamai Status

Updated

Akamai Multi Factor Authentication (MFA) issues

Incident Report for Akamai

Resolved

We identified an issue with Akamai MFA between 4:30 UTC and 5:20 UTC on May 13, 2025 where users were unable to access sites that required MFA authentication and experienced "Site cannot be reached" errors. While our SMEs were actively investigating the issue, the services resumed normal operations without Akamai taking any actions. We are in the process of determining the root cause and will take necessary actions. We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent recurrence. 
Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D5a700000PTEg9CAH
Posted May 13, 2025 - 05:54 UTC
This incident affected: Enterprise Security (Akamai MFA).