Akamai Status

Updated

EAA MFA Authentication Token Issue via Email

Incident Report for Akamai

Resolved

The issue affecting Enterprise Application Access (EAA) multi-factor authentication (MFA) tokens sent via email has been fully resolved. After monitoring the situation, we can confirm that everything is functioning as expected. We appreciate your patience throughout this incident. If you encounter any further issues, please don’t hesitate to reach out.
Posted Mar 15, 2025 - 00:50 UTC

Monitoring

We have implemented a fix for the issue affecting Enterprise Application Access (EAA) multi-factor authentication (MFA) tokens sent via email. Other forms of MFA have been functioning normally throughout this incident. While we believe the issue has been resolved, we will continue to monitor the situation over the next few hours to ensure stability. Thank you for your patience.
Posted Mar 14, 2025 - 23:54 UTC

Investigating

We are investigating an emerging issue with a third-party service provider affecting Enterprise Application Access (EAA) multi-factor authentication (MFA) tokens sent via email. Other forms of MFA are working normally at this time. We are working closely with the service provider and actively investigating the issue, and we will provide another update as soon as possible.

We will soon be posting more details for customers and partners with a valid Control Center login at https://community.akamai.com/customers/s/group/0F90f000000DFgx/service-incident-notifications.

If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community, or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted Mar 14, 2025 - 23:14 UTC
This incident affected: Enterprise Security (Enterprise Application Access).